IMPORTANT How to run Windia on M1 Macs

Jacob

wallace05
Contributor
Oct 19, 2019
130
84
28
If you are not on an M1 Mac, please consider using WINE in order to run Windia.

1. Install Crossover from https://www.codeweavers.com/crossover/download

2. Install this Windia bottle https://drive.google.com/file/d/17LwMCOu5UMNEwicIbVCVg58TUYRGsKSi/view?usp=sharing

3. Run the Windia.cxarchive file and create the bottle

4. Double click the Windia program in your bottle to play, or Windia Patcher to patch your files

NOTE: It may take 30-60 seconds for the program to run depending on your system, this is normal.

IMPORTANT NOTE: Please, if you run into bugs such as severe lag, crashing, hanging, etc., please make a report on the forum including SEH logs. I've included a way to show you how to create these logs below. This will help shavit the most with fixing bugs with CrossOver on Mac as shavit does not have a Mac to do her own debugging. Without these, it will be impossible to fix anything.

1. Right click the Windia program and click "Run with Options..."

2. Tick "Create log file" and type in the log channel "+seh"

3. Click run

1. Launch Crossover at least once, then close it.

2. Download PlistEdit Pro from https://www.fatcatsoftware.com/plisteditpro/

3. Open your Home folder: Macintosh HD⁩ ▸ ⁨Users⁩ ▸ ⁨[insert user]

4. Press Command + Shift + G and type:
library/preferences

4. Open "com.codeweavers.CrossOver.plist" with PlistEdit.

5. Change "FirstRunDate" to sometime in the wayyy future, then save it.

6. Your trial period is extended!

1. Create a new bottle (Windows 10 64-bit preferably) by going to Bottle > New Bottle in the menu bar

2. Copy and paste your Windia folder from your previous Windia bottle into your newly created Bottle by right clicking your previous Bottle in the Bottles list on Crossover and opening the C: Drive

3. In your newly created Bottle, in "Run Command..." click Browse, navigate to your Windia folder you copied into your drive_c folder, and open the Windia Patcher.exe.

drive_c > Program Files > Windia > WindiaPatcher.exe

OPTIONAL: Save as launcher so it shows up in your Programs in the Bottle menu.

4. Run Windia as you normally would through the Windia Patcher.

5. You can delete your old bottle.

Run the file through run command, then you can save it again as a launcher after that.
drive_c > Program Files > Windia > WindiaPatcher.exe
 
Last edited:

Jacob

wallace05
Contributor
Oct 19, 2019
130
84
28
Added a section in case you get a Trial error when running Windia. I will add pictures later whenever I get to it (I hate xenforo and it's hard to add images).
 

Tiffaux

New member
Apr 22, 2022
3
0
1
Add Windia.exe. Not MapleStory.exe.
In which map should windia.exe be? I can't seem to find it

Edit:
I got a trojan horse detection and I've lost the file. I'm downloading Windia bottle again and check what happens

Edit2:
I have fully disabled my bitdefender, deleted everything and redownloaded it.
I now got this error:


What should I do next?
 
Last edited:

Jacob

wallace05
Contributor
Oct 19, 2019
130
84
28
CXArchive file updated. Please download the new one if the old one is not working.
 
  • Like
Reactions: shavit

Flump

New member
May 6, 2022
2
0
1
Hello! I am currently running on an intel Mac using CrossOver. I have an issue with massive unplayable lag in towns only. As soon as I move maps (given it takes like 10 minutes to move and click a portal) the lag immediately goes away and I can play normally. Any advice on how to not lag in towns so I can adequately play the game?
 

shavit

/dev/null
Staff member
Oct 19, 2019
1,835
883
113
Hello! I am currently running on an intel Mac using CrossOver. I have an issue with massive unplayable lag in towns only. As soon as I move maps (given it takes like 10 minutes to move and click a portal) the lag immediately goes away and I can play normally. Any advice on how to not lag in towns so I can adequately play the game?
Just use wineskin if you're on an Intel CPU
 

heyojayo

New member
Jun 7, 2022
1
0
1
Hey! The patcher does not seem to work for me. It is returning

Command error text:
-[MTLTextureDescriptorInternal validateWithDevice:]:1248: failed assertion `Texture Descriptor Validation
The compressed pixel format MTLPixelFormatBGRG422 cannot be used with MTLTextureType3D.
MTLTextureDescriptor: MTLPixelFormat422 requires MTLTextureType2D.
'
wine: Assertion failed at address 2031C462 (thread 00b0), starting debugger...

This running through Run Command as running the patcher from the menu doesn't launch.

I am on M1 AIr
 

shavit

/dev/null
Staff member
Oct 19, 2019
1,835
883
113
Hey! The patcher does not seem to work for me. It is returning

Command error text:
-[MTLTextureDescriptorInternal validateWithDevice:]:1248: failed assertion `Texture Descriptor Validation
The compressed pixel format MTLPixelFormatBGRG422 cannot be used with MTLTextureType3D.
MTLTextureDescriptor: MTLPixelFormat422 requires MTLTextureType2D.
'
wine: Assertion failed at address 2031C462 (thread 00b0), starting debugger...

This running through Run Command as running the patcher from the menu doesn't launch.

I am on M1 AIr
 

sportsports

New member
Jun 10, 2022
1
0
1
Hello could you help? Works then closes out before im able to pick a world. Display Resolution seems to be incompatible. We have made these changes for you. Edit Windia.ini to make these changes permanent. Pops up before loading then loads sometimes.
 
Last edited:

Tiffaux

New member
Apr 22, 2022
3
0
1
windi.ini + resolution + dc/bug question :)

I get this window every time I open up Windia: https://ibb.co/tQcjYXT

Could someone explain how to get to the .ini file?
I've found something about it being in a hidden folder and I should use a command to make a whole new section of folders visible. I feels like a maze, help pl0x n_n"


Also, when playing Windia after some time I dc, sometimes with prior glitches. When trying to start Windia it sometimes takes up to 7 times before it starts (I do wait ±60 seconds after hitting launch). And even if it starts, most of the times the first couple of times I dc right after filling out my pin/pic (the 6 digit nr after char selection).
When I went to Vera, the only way I was able to farm was when putting almost everything off at @settings and turn gfx to low. I've also tried doing pinkbean but dc'd during the run as well.

My question: is the latter caused by the resolution pop-up and therefore will be fixed when finding the .ini? If not, are these bugs gonna be looked at and try to be fixed by staff?

Thank you in advance 🍁
 
Last edited:

Jacob

wallace05
Contributor
Oct 19, 2019
130
84
28
windi.ini + resolution + dc/bug question :)

I get this window every time I open up Windia: https://ibb.co/tQcjYXT

Could someone explain how to get to the .ini file?
I've found something about it being in a hidden folder and I should use a command to make a whole new section of folders visible. I feels like a maze, help pl0x n_n"


Also, when playing Windia after some time I dc, sometimes with prior glitches. When trying to start Windia it sometimes takes up to 7 times before it starts (I do wait ±60 seconds after hitting launch). And even if it starts, most of the times the first couple of times I dc right after filling out my pin/pic (the 6 digit nr after char selection).
When I went to Vera, the only way I was able to farm was when putting almost everything off at @settings and turn gfx to low. I've also tried doing pinkbean but dc'd during the run as well.

My question: is the latter caused by the resolution pop-up and therefore will be fixed when finding the .ini? If not, are these bugs gonna be looked at and try to be fixed by staff?

Thank you in advance 🍁
If you're using the bottle supplied in this thread, it should be in drive_c > Program Files > Lossdia/Windia. You can access your bottle's files from right clicking the bottle in Crossover.

To address your other concerns, ARM compatibility is certainly not a high priority, so will there ever be a fix? Who knows. You will have to live with crashing every now and then and sometimes it'll be hard getting into the game. If you want an easier time playing, use Parallels or UTM.
 
  • Like
Reactions: Tiffaux

jcxl

New member
Jun 20, 2022
1
0
1
When i run windia.exe it says not updated.
But when I run the patcher, update and click launch windia thru the patcher window, nothing happens.
Pls halp~